paiza開発日誌

IT/Webエンジニア向け総合求人・学習サービス「paiza」(https://paiza.jp ギノ株式会社)の開発者が開発の事、プログラミングネタ、ITエンジニアの転職などについて書いています。

初心者でも小1時間でプログラムが書けちゃう!【なでしこ】がすごい件

f:id:paiza:20161209195727j:plain
Photo by Durán

f:id:paiza:20140916135428p:plainこんにちは。今回は谷口がお送りします。

先日このブログで、Smalrubyを使って実際に弊社社員にビジュアルプログラミング学習をしてもらい、FizzBuzzのシステムを作ってもらったというお話をしました。


初心者が簡単にRubyプログラミングを覚えられる!Smalrubyの使い方 - paiza開発日誌

そこで今回は、その次のステップとして日本語でプログラミングができる言語なでしこ』を使って、プログラミングの学習をしてもらいましたので、その過程をご紹介していきます。

なでしこは、単語も文法も日本語に沿った形でコードが書けるので、これからプログラミングを学ぶ初心者の方には最適の教材になると思います。

ちなみにやってもらったのは、普段は事務を担当しており、プログラミング経験はビジュアルプログラミングのみ、条件文やループの概念に関しては、SmalrubyFizzBuzzが作れる程度には理解している……という弊社女性社員ですので、初心者のサンプルとしては最適な人材だと思います。

■なでしこの環境設定をしてみよう

f:id:paiza:20141201191144p:plain

なでしこの公式サイトからなでしこの実行環境をインストールします。


なでしこ:日本語プログラミング言語

f:id:paiza:20141201191515p:plain

ZIP版とEXE版があって、特に違いはないそうですが、EXE版の方が簡単だそうなのでEXE版をダウンロードします。(※PCによってはZIP版からしかインストールできない場合もあるそうです)

EXE版をダウンロードし、クリックしますと書庫が展開されまして
f:id:paiza:20141201143228p:plain

インストール先を指定して(そのままProgram Filesで良いかと思いますが)実行しますと
f:id:paiza:20141201143258p:plain

インストールが始まりまして
f:id:paiza:20141201143445p:plain

完了です。インストール先の『nadesiko_lang』フォルダに行きましょう。
f:id:paiza:20141201143456p:plain

nadesiko_lang』フォルダ内の『nakopad』をクリックしますと……
f:id:paiza:20141201143801p:plain

なでしこが起動しました~!簡単!
f:id:paiza:20141201143902p:plain

■なでしこを触ってみよう

f:id:paiza:20141201191726p:plain
なでしこを起動すると、まず『なでしこのはじめに』画面が出てきますので、ここでなでしこについての説明や、デモとしてなでしこで作られたグラフィックやゲームで遊ぶことができます。

なでしこについての説明
f:id:paiza:20141201145507p:plain

デモにはどっかで見たことあるような……ゲームがたくさんあります。実際に遊べて楽しい。

なでりす
f:id:paiza:20141201184652p:plain

なでリバーシ
f:id:paiza:20141201184704p:plain

チュートリアルをやってみよう

f:id:paiza:20141201145950p:plain
なでしこのチュートリアルは公式サイトを見てみましょう。


プログラミング基礎編

Hello world的なところからコードの書き方を詳しく説明してくれていますのでやってみます。
f:id:paiza:20141201192028p:plain

チュートリアルのとおりエディタにコードを書きます。『クジラが「こんにちは」と言う。』
f:id:paiza:20141201192328p:plain

実行すると……クジラが出てきて「こんにちは」と言ってくれました!
f:id:paiza:20141201152550p:plain

閏年判定システム作ってみよう

簡単なチュートリアルをいくつかやってもらった後で、弊社社員に「画面で入力した西暦の年数が閏年かどうか判定するシステム作ってみて~」という問題を出してみました。閏年判定問題懐かしい。新卒の時のC言語研修でやりました。

実はチュートリアルの中にも閏年判定の問題はあるのですが、計算式は見ないで調べてやってもらいました。あと入力画面の出し方も調べながらやってもらいました。

チュートリアルや公式の命令一覧の他にも、実際にいろいろ作ってみた方のブログ等も検索するとたくさん出てきますので、なでしこは独学でもいろいろなシステムを作ることができると思います。

そして弊社の初心者社員が小一時間いろいろ調べながら書いてもらったコードがこちらです!結果判定として表示される文章が……ゆるい。

「西暦を入力してください」と尋ねる。
西暦はそれ。

もし(西暦%4)=0ならば
	もし(西暦%100)=0ならば
		もし(西暦%400)=0ならば
			「閏年です!!o(≧▽≦)o」と表示。
		違えば
			「閏年ではありません…(´・ω・`) 」と表示。
	違えば
		「閏年です!!o(≧▽≦)o」と表示。
違えば
	「閏年ではありません…(´・ω・`) 」と表示。

実行してみます!

入力画面が出た!
f:id:paiza:20141201165223p:plain

西暦を入力して決定ボタンを押します。
f:id:paiza:20141201165345p:plain

結果が表示されました!
f:id:paiza:20141201185011p:plain

入力値を変えると……
f:id:paiza:20141201165456p:plain

ちゃんと結果が判定されています!
f:id:paiza:20141201185024p:plain

このシステムは初心者でも1時間ほどで作成できたそうです!

■まとめ

なでしこ閏年判定システムができるまで、いかがだったでしょうか。

いきなりプログラミング言語を触るのはハードルが高い……という場合に、なでしこ日本語の言語感覚でコーディングができ、また環境構築も簡単にできてすぐに動かせるところがとても良いと思います。

プログラミング初心者で、いきなり一般的なプログラミングを勉強するのは敷居が高いな~と感じている皆さん、まずはなでしこを使ってみてはいかがでしょうか。

ちなみに、今回弊社社員に作ってもらった閏年判定システムの処理がコードで書けるようになりますと、paizaではDランクに相当するレベルの実力がついたということになります。ある程度なでしこに触れてプログラミングの基礎が身についてきたなと思いましたら、ぜひpaizaでご自分のスキルレベルをはかってみてください

また、「実際のプログラミング言語でのコーディングを学びたい!」という方は、ぜひ無料オンラインプログラミング実行環境サービスpaiza.IO』もご活用ください。

paiza.IO』は、環境構築の手間ゼロでブラウザ上でコードが書け、書いたコードをその場で実行できるオンラインのプログラム実行環境です。




paizaラーニング」では、未経験者でもブラウザさえあれば、今すぐプログラミングの基礎が動画で学べるレッスンを多数公開しております。

↓詳しくはこちら
paiza.jp

そして、paizaでは、Webサービス開発企業などで求められるコーディング力や、テストケースを想定する力などが問われるプログラミングスキルチェック問題も提供しています。
paiza.jp
スキルチェックに挑戦した人は、その結果によってS・A・B・C・D・Eの6段階のランクを取得できます。必要なスキルランクを取得すれば、書類選考なしで企業の求人に応募することも可能です。「自分のプログラミングスキルを客観的に知りたい」「スキルを使って転職したい」という方は、ぜひチャレンジしてみてください。

ITプログラマ・エンジニア向け転職・就活・学習サービスのpaiza


プログラミング入門講座|paizaラーニング

PHP入門編Ruby入門編Python入門編Java入門編JavaScript入門編C言語入門編C#入門編アルゴリズム入門編